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Optimize your digital photo management workflow

most key workflow tasks (Figure 1.1).
Workflow automation: Using scripts, you can 

automate tasks or a sequence of batch processes. 
MediaPro can also be scripted to perform a series 
of tasks with 3rd-party applications, Web services 
or database systems. 

Customize the workspace: Another way to in-
crease efficiency and productivity is to customize 
MediaPro’s interface and features, tailoring them 
to meet your workflow needs. 

Of course, your workflow will be dictated by 
many variables: customer requirements, business 
goals, staffing, in-house equipment, 3rd-party 
software, distribution methods and the amount 
of images produced. Regardless, the key to a suc-
cessful, efficient workflow is to pay close attention 
to details, batch or automate as many tasks as pos-
sible, and follow a consistent routine.

Creating libraries of digital images can be a compli-
cated, time-consuming and costly exercise. Photo 
management workflows that simplify the process 
while being cost effective are a crucial component 
of your businesses’ success.

Professional photographers need to minimize 
the amount of time spent managing their media 
and maximize the time to create, market and sell 
assets. This is where iView MediaPro excels. Medi-
aPro’s flexible, streamlined automation tools make 
organizing, editing, repurposing, distributing, and 
archiving digital images effortless. 

This paper covers three techniques to save time 
and money, as well as optimize your photo man-
agement workflow with MediaPro.

Batch processing: A batch process is a func-
tion that can be applied to a group of images. 
MediaPro has integrated batch capabilities with 

Figure 1.1: Batch processing is integrated into key tasks to minimize the amount of time you spend managing images.
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A batch process is a function that can be applied 
to a group of images in a catalog. MediaPro has 
integrated batch capabilities with most key tasks 
to help you save time and money, as well as 
streamline your workflow.

Making selections
To batch items, you must begin by making a se-
lection of more than one item. There are several 
ways to select a group of items: 

1. Selection commands: Choose Edit › Select All, 
Deselect All or Invert Selection.

2. A continuous block of items: Select the first 
item and, holding down the Shift key, select the 
last item for your selection.

3.  A selection of non-adjacent items: Hold 
down the Ctrl key (Mac: Cmd key) while select-
ing individual items.

4. A selection of non-adjacent blocks:  
For example, to select items 1-10 and 20-30: 
click 1, Shift-click 10, Ctrl-click 20 (Mac: Cmd-
click), Shift-click 30.

5. Expanding a selection: Select an item or 
block of items and expand the selection by 
pressing the Shift key and one of the arrow 
keys. The left and right arrows increase the 
selection by one item; the up and down arrows 
increase the selection by a row of items.

6. Selection scripts (Scripts › Select):  All Land-
scape will select all items in the catalog that 
are horizontal. All Portrait will select all items 
that are vertical. 

7. Selecting based on criteria: To select items 
that match a particular attribute or annota-
tion field, click on dot next to a field term in 
the Organize Panel’s Catalog Fields index and 
the corresponding items appear in the ac-
tive view. This will hide all images that do not 
match that annotation or attribute. Once the 
appropriate images are showing in the active 
view, choose Edit › Select All. Now you are ready 

to perform a batch process. An alternative op-
tion is to choose Select Media Items from the 
individual field drop-down menu (Figure 1.2). 
This will select all items associated with that 
attribute in the active view. 

Batch process images

Figure 1.2: Individual field menus offer the 
option to select images associated with that 
field in the active view.

Click the dot next to any field term and the 
corresponding items will appear in the active view.
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Moving images in catalogs 
To rearrange images in a catalog, select a group of 
images and drag-and-drop them to a new location 
(Figure 1.3). 

You can also rearrange images using the func-
tions: View › Move to Top, Bottom, Location or 
Move Again.  These functions enable you to move 
images to the top or bottom of a catalog or to a 
specific location in the catalog.  

When you choose View › Move to Location, this 
option will turn the cursor into a cross hair. At this 
point, you can use the scroll bar to go to any loca-
tion in the catalog, then place the cross hairs at the 
desired location and click. Your images will drop 
into the chosen location. This feature is useful for 
moving images round a large catalog, where most 
images are not visible in the viewing area.

Move Again will repeat the last move made in 
the catalog, whether it be to the top, bottom, loca-
tion or a manual drag-and-drop.

Labeling, ranking and marking 
Color labels provide a visual identification and clas-
sification scheme for images in a MediaPro catalog. 
Star ratings provide a ranking system for items in 
your catalogs. After labeling or rating images, you 
can quickly display them using the Find › Show La-
beled or Show Rated command.

See page 27  for more on reviewing and marking 
images in a catalog.

Assign a label or rating
Select a group of images and either: 

• Toolbar: Choose a color from the Assign 
Label drop-down menu in the toolbar; 
Choose a star rating from the Rate Media 
drop-down menu in the toolbar, or contextual 
menu in any view.

• Hotkeys: To assign a color label, press a num-
ber key (1 through 9). This will apply the asso-
ciated color (e.g. 1 = Red). To assign a star rat-
ing, press Alt + a number, 1-5 (Mac: Ctrl+1-5).

• Organize Panel: Drag-and-drop items onto 
the color values in the Labels section or Rat-
ing section of the Catalog Field index. 

Once a color label has been assigned to an 
image, the media frame (border) and display text 
will appear in that color in all views (Figure 1.4).

Figure 1.3: When dragging images to a location, a black bar appears in the location where the images will be placed.

Figure 1.4: Labeling images changes the color of the 
media frame (border) and display text in all views. 
Labels and ratings can be changed by clicking directly 
on the color swatch or stars.
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File renaming
Good digital asset management strategy starts 
with having unique, meaningful filenames. For 
creative professionals — who can easily produce 
huge volumes of media in a relatively short time 
— this is particularly important.

When an image collection grows past a thou-
sand files it is easy to have filename problems, 
such as having two images with the same name. 

Most digital cameras have a sequential photo 
numbering option. With this option on, every image 
will have a unique filename, such as DSC0211.jpg, 
DSC0212.jpg, DSC0213.jpg, etc.

Sequential numbers allow you to move files 
around easily without having to rename them to 
avoid duplication of filenames. Sequential numbers 
are also useful when you must find other photos 
that were taken at the same time or in the same 
place.  However, sequential numbering is only part 
of the solution to a good filename. 

Filenaming  conventions
A valuable filename also includes additional infor-
mation such as date, author, client name, project 
name or subject of a photo shoot. It also might 
contain business-related information such as prod-
uct or part numbers (Figure 1.5). 

Standardizing on a particular filenaming con-
vention offers several advantages for photo man-
agement workflows:

• It is difficult to create two files with the same 

filename. This makes them easier to identify 
and reduces problems with duplication. 

• If you always include a standardized date in 
the filename, such as the Capture Date, you 
can easily locate a file. 

• With sequentially numbered files, a folder 
of images on your desktop is automatically 
sorted into chronological order. 

• Workgroups use the same conventions, 
thereby promoting consistency across the or-
ganization and facilitating file retrieval.

• By looking at just the filename, you will know 
a lot about the image (i.e. date created, person 
who took the image, subject or client, and the 
order in which it was created). 

• If you decide to switch image management 
applications, or are running several database 
applications, important metadata can be de-
rived from the filename.
Your filenaming convention should be spe-

cific to your business and archiving needs. For a 
large catalog of stock  images, you could use the 
Dewey Decimal or U.S. Library of Congress system 
to identify the subject of the photographs. 

The key is to integrate the naming system into 
your workflow so that every file is named properly 
before it ends up in an archive.

Ultimately, if you create specific guidelines for 
filenaming and stick to them, you and everyone 
you work with will be able to easily identify, locate 
and share those files. 

Filename examples Name components

lexus_newsletter_0904_001.tif Client name, project, publication date and sequential numbering

wegatv_KDF42WE655_012.jpg Product name, product ID and sequential numbering

hourmedia_040623_066.pdf Client name, 6-digit date (YYMMDD) and sequential numbering

hollywood_040721_0457.jpg Subject, 6-digit date (YYMMDD), slide ID (for scanned images)

smith_jones_040721_sb_0215.jpg Bride, groom, 6-digit date (YYMMDD), creator’s initials, sequential numbering

job314_040727_0013.jpg Job number, 6-digit date (YYMMDD), sequential numbering

20040721_P_0525.jpg 8-digit date (YYYYMMDD), subject code (Portrait) and sequential numbering

Figure 1.5: For recommendations for image filenaming strategies, see David Riecks’ Controlled Vocabulary web site. 
http://www.controlledvocabulary.com/imagedatabases/filenaming.html
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Batch renaming in MediaPro
To rename all selected catalog items, as well as the 
corresponding original files, choose Action › Batch 
Rename. The Batch Rename function provides 
four options for renaming files: Date, Text, Sequen-
tial Numbering, and Filename. Up to three options 
can be combined in various ways to create unique 
batch renaming instructions.

Example 1 - Incremental: Use the date, a string of 
text and numbering sequence for renaming your 
items (Figure 1.6).
1. Select a group of items and choose Action › 

Batch Rename. If you select a single image, the 
function will be not be available.

2. Choose Date from the Rename Options drop-
down menu. This function will automatically 
insert either the IPTC Event Date, the EXIF 
Capture Date or the file Creation Date in that 
priority.  MediaPro will display date tags, such 
as MM-DD-YYYY, which you can reorder and 
use different separators, such as YY_DD_MM.

3. Click the plus sign (+) button to add another 
Rename Option. Choose Text in the Rename 
Options drop-down menu. 

4. Enter a text string: For example, a string might 
be a subject, location or the photographer’s 
initials. Use text that will be meaningful to all 
items being renamed.

5. Click the plus sign (+) button to add another 
Rename Option. Choose Number From in the 
Rename Options drop-down menu. 

6. Define starting increment: An increment is the 
numeric value that is used to start sequential 
numbering. For example: if you type “10”, files 
will enumerate: sb10.jpg, sb11.jpg, sb12.jpg, etc.  
Incremental renaming ignores file types and 
will continue to incrementally enumerate 
regardless of the file type. This means that if 
your first two files are TIFFs and the next two 
are JPEGs, then they would be named: 1.tif, 2.tif, 
3.jpg, 4.jpg.

7. In the field next to the increment, define num-
ber of digits for the sequential numbers. For 

For repeat use of your 
settings, save them 
using the Option Sets 
pop-up menu. 

Change case to:
lowercase, UPPERCASE 
or Title Case.

Preview window 
shows a list of your 
files before and after 
the batch rename.

Date uses the IPTC 
Event Date, the EXIF 
Capture Date or the 
file Creation Date to 
rename items. 

You can adjust the date 
using various tags:

MM = Month
DD = Day
YYYY = 4-digit Year
YY = 2-digit Year
hh = Hours
mm = Minutes
ss = Seconds

Adjust the zero padding 
by defining the number 
of digits for sequential 
numbering.

Figure 1.6
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example, if you choose a starting increment of 
8 and 3 digits, files will be named: 008, 009, 010.

8. Click the Rename button. File renaming 
should be relatively instantaneous, but might 
take a few seconds if you are renaming more 
than a thousand files. 
Tip: MediaPro remembers the last increment 

used in batch renaming and automatically pro-
vides you with the next increment for additional 
batches. For example, if you renamed 50 files, then 
later added more files that you wish to rename, 
the Number From field would automatically show 
51 as starting value for your next batch rename.

Example 2 - Search & Replace: In this method of re-
naming, you can search for text and replace it with 
more relevant information. This function is good 
for turning sequential digital camera filenames 
into ones that match your filenaming convention, 
while maintaining the sequential numbers created 
by your camera (Figure 1.7).
1. Select a group of items and choose Action › 

Batch Rename. If you select a single image, the 
function will be not be available.

2. Choose Date from the Rename Options drop-
down menu. 

3. Click the plus sign (+) button to add another 
Rename Option. Choose Filename in the Re-
name Options drop-down menu. 

4. In the Search for field, enter a text string that 
you want to replace. In this case, use the string 
“DSC” (common to digital cameras). 

5. Replace it with a string that follows your 
filenaming convention, such as subject or 
photographer’s initials.  

6. Case sensitive: Check this box to restrain your 
search based on the case of the text. 

7. Click the Rename button. Now we have turned 
DSC09851.jpg into a more usable filename: 
20051020_sb_nyc_09851.jpg.
Format Options: For all batch renames, you 

can change the case of all text to: lowercase, UP-
PERCASE or Title Case. There is also options to strip 
diacritical marks such as accents. For example, you 
could change “déjà vu” to “deja vu”. Stripping diacrit-
ical marks from filenames is important for increas-
ing filename compatibility across platforms.

File renaming scripts
• Rename using Text File (Scripts › Files): This 
script uses each line of a text file as a new 
name for the selected media items.

Troubleshooting file renaming
• Offline catalog items, such as those on CD, DVD 
or removable drives, cannot be renamed.

• Files that are locked by the operating system 
cannot by renamed.

Filename compatibility
For maximum portability across Windows, Macin-
tosh, and Unix networks and platforms: 

• Limit filename length to 31 characters
• Keep filename extensions, such as .jpg, .gif.
• Use underscores ( _ ) to separate blocks of in-
formation, instead of dashes or spaces.

• Format dates in a 6 or 8-digit code. For exam-
ple, July 21, 2004 should be 040721 (YYMMDD), 

Figure 1.7: Example showing search and replace.



�    iView MediaPro Workflow Solutions

or 20040721 (YYYYMMDD). This will help keep 
files sorted in their proper order in the folders 
on your desktops and removable media.

Batch renaming Raw + JPEG
iView MediaPro 3 does not have a specific function 
to batch rename Raw+JPEG simultaneously.  How-
ever, MediaPro’s batch rename feature can simulta-
neously rename Raw+JPEG, if you are willing to use 
the original sequential numbering created by your 
digital camera. Here’s how it done:

Raw+JPEG, Example 1 (Figure 1.8)
1. Import your Raw and JPEG files into a 

MediaPro catalog.
2. Sort the catalog by filename. This can be done 

by choosing Filename the Sort toolbar menu. 
Your catalog should now have Raw and JPEG 
files of the same name next to each other.

3. Select all items in the catalog and choose Ac-
tion › Batch Rename.

4. Choose Date from the Rename Options drop-

down menu. This function will automatically 
insert the EXIF Capture Date for digital camera 
images.  MediaPro will display date tags, such 
as MM-DD-YYYY- hh-mm-ss, which you can 
reorder and use different separators, such as 
YY_DD_MM.

5. Click the plus sign (+) button to add another 
Rename Option. Choose Text in the Rename 
Options drop-down menu. 

6. Enter a text string: For example, a string might 
be a subject, location or the photographer’s 
initials. Use text that will be meaningful to all 
items being renamed.

7. Click the plus sign (+) button to add another 
Rename Option. Choose Filename in the 
Rename Options drop-down menu.  This func-
tion appends the original filename to the new 
name.

8. In the Search for field, enter a text string that 
you want to remove. In this case, use the string 
“DSC_” (common to digital cameras).  By doing 
this, we are maintaining the sequential  

For repeat use of your 
settings, save them 
using the Option Sets 
pop-up menu. 

Preview window 
shows a list of your 
files before and after 
the batch rename.

Date uses the EXIF 
Capture Date when 
renaming digital 
camera files. 

You can adjust the date 
using various tags:

MM = Month
DD = Day
YYYY = 4-digit Year
YY = 2-digit Year
hh = Hours
mm = Minutes
ss = Seconds

Enter a string of 
text that you want 
to remove from the 
original filename. In 
this example, we are 
appending the original 
filename to the new 
name, but stripping 
out the “DSC_” text. 
This effectively adds 
the original sequential 
numbering created by 
the digital camera.

Figure 1.8: 
Batch rename Raw + 
JPEG Example 1
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numbers created by your camera (Fig. 1.8).
9. In the Preview window, notice that MediaPro is 

going to rename the Raw and JPEG files in the 
same manner.

10. Optional: In the upper right hand corner of 
the batch rename dialog, there is an Option 
Set drop-down menu. This menu is useful for 
storing and recalling batch rename options. 
In this menu, choose Save as and name your 
Raw+JPEG renaming options. This way, you can 
easily recall these settings on future catalogs.

11. Click the Rename button. Now we have 
batch renamed Raw and JPEG files using the 
sequential numbering created by the digital 
camera.
Tip: MediaPro remembers the last increment 

used in batch renaming and automatically pro-
vides you with the next increment for additional 
batches. For example, if you renamed 50 files, then 
later added more files that you wish to rename, 
the Number From field would automatically show 
51 as starting value for your next batch rename.

Raw+JPEG, Example 2: If you want to create 
your own sequential numbers when renaming 
Raw+JPEG files, you will need to run two batches 
— one for the Raw files and one for JPEGs .
1. Open the Organize Panel. Reveal the File Type 

annotation group in the Catalog Fields index 
by clicking the arrow.

2. Click on the dot (Figure 1.9) next to the num-
ber of JPEG files. This will make MediaPro 
show only JPEG files in the catalog.

3. Select all JPEGs and choose Action › Batch 
Rename.

4. Add your Date and Text strings as needed.
5. Click the plus sign (+) button to add another 

Rename Option. Choose Number From in the 
Rename Options drop-down menu. 

6. Define starting increment: An increment is the 
numeric value that is used to start sequential 
numbering. For example: if you type “10”, files 
will enumerate: sb10.jpg, sb11.jpg, sb12.jpg, etc. 
(Figure 1.10).

7. In the field next to the increment, define num-
ber of digits for the sequential numbers. For 
example, if you choose a starting increment of 
8 and 3 digits, files will be named: 008, 009, 010.

8. Click the Rename button. File renaming 
should be relatively instantaneous, but might 
take a few seconds if you are renaming more 
than a thousand files. 

9. Repeat steps 2-8 for the Raw files. 

Figure 1.9: Click the dot next to JPEG in the File Type 
annotation group in the Organize Panel. This will make 
MediaPro show only JPEG files in the catalog, making 
them available to rename. After renaming them, repeat 
this process, filtering by Raw files.

Figure 1.10: Batch rename Raw + JPEG, Example 2
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Rotating thumbnails
Some images will not appear in the proper orienta-
tion when imported into MediaPro. This is often the 
case with portrait (vertical) film images that have 
been scanned, or portrait images taken with digital 
cameras that do not record the camera’s Orienta-
tion in the EXIF metadata. 

Most newer digital cameras record the orienta-
tion in the EXIF metadata. MediaPro respects this 
image orientation and automatically rotates the 
image thumbnail accordingly during the import 
process.

For those files that need to be rotated, MediaPro 
offers three methods of rotating your files to the 
proper viewing orientation. 

1. Rotating thumbnails or “soft rotation”:  
A soft rotation means that the viewing angle of an 
item is rotated, but not the file itself. To soft rotate an 
item, select the thumbnail and use the Rotate but-
tons in the far right side of the Header bar (Figure 
1.11). Each rotation represents 90 degrees. 

A soft rotation applies to how MediaPro will 
display the file in all views (List, Thumbnail, Media 
View, Lightbox mode and Slide Shows) and how it 
will export the media, such as file conversions and 
Web galleries. However, if you open the file with an 
external application, such as Photoshop, the media 
may appear with its original orientation.

2. Lossless JPEG rotation: Lossless rotation 
means that the original image is rotated and saved 
without a recompression of the JPEG image data. 
Using this method will prevent images from get-
ting more JPEG compression artifacts. MediaPro’s 
JPEG Rotate command (Action menu) will perform 
lossless rotations of 90, -90 and 180 degrees. Be-
fore applying a batch lossless JPEG rotation, be 
sure that all images selected are JPEGs and need 
the same orientation correction. All original anno-
tations are maintained with this function.

MediaPro’s new Default lossless JPEG rotation 
function rotates JPEGs based on their soft rotation 
state. Using this option will save you alot of time 
because you are able to perform several different 
rotations at the same time. 

3. Precision rotation: The Rotate tool in Media-
Pro’s Image Editor is used to adjust the angle of im-
ages in increments as small as 1/10th of a degree. 
To rotate an image 90 degrees clockwise, just type 
90 into the Angle field. To rotate counter clockwise, 
place a negative sign (-) in front of the number in 
the Angle field. When you are done, click the Save 
button in the Image Editor palette. Depending on 
your options (particularly format), some metadata 
might be lost when saving the file. 

See page 13 for instructions on how to batch files 
with the Image Editor.

Figure 1.11: Some images will not appear in the proper 
orientation when imported into MediaPro (A). To correct 
this, select your images in Thumbnail View, then click 
the appropriate Rotate button in the far right side of the 
Header bar (B). Each click will rotate the image 90 degrees. 
This sets the viewing angle of an item in all views and 
does not change the rotation of the original file.  

A

B

Rotate 90° clockwiseHeader bar
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Annotating
MediaPro allows you to batch assign and edit an-
notations for multiple images, providing you with 
a quick method of organization. There are four 
ways to batch annotations: during import;  apply-
ing metadata templates; data entry in the Info Panel; 
and drag-and-drop to the Catalog Fields index.

On Import/Ingestion
In the Import Items from Camera, Disk and URL op-
tions (File menu), you can define a metadata tem-
plate to be applied to every media item during 
import (Figure 1.12).

Info Panel
MediaPro uses the Info Panel to provide an easy 
way to quickly review the aggregate properties 
and metadata of an image. You can also use the 
Info Panel to assign annotations to single item or 
to a batch selection of media items. 
1. Select the image(s) to annotate. 
2. Open the Info Panel: Click on the Info toolbar 

button or select Window › Display › Info Panel.
3. Enter data: Type your information into the 

desired Annotations fields (e.g. Caption, Event 
Date, Keywords or Categories). 

4. Apply changes: Click the checkmark icon at 
the top of the Info Panel to confirm changes (or 
the X icon to discard changes).

5. Batch: In the confirmation dialog, select Apply 
to All images. Now all selected images have the 
annotations you entered.

Metadata templates
MediaPro provides metadata templates — a tool 
for saving a set of frequently used annotations 
and applying them to images. In previous versions 
of MediaPro, templates were called AutoFills.

A metadata template applies Annotations, Peo-
ple, Keywords, Scenes, Subject Codes, Categories and 
Descriptions to each item selected in the catalog.

To create a metadata template:
1. Select an image and enter information into all 

Figure 1.12: Choose 
a metadata template 
from this drop-down 
menu to apply a 
group of pre-defined 
annotations to all 
downloaded files. If 
there are no templates 
available, you can create 
one by selecting New 
Metadata Template. 

Figure 1.13: Metadata templates are useful for saving 
and applying a group of frequently used annotations.
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annotation fields you wish to save.
2. In the drop-down menu at the top of the Info 

Panel (Pencil icon), choose Save Metadata Tem-
plate (Figure 1.13) and name your template. 
Alternatively, you can choose Create Metadata 

Template in the drop-down menu at the top of 
the Info Panel (Pencil icon). Metadata templates 
can also be created during the Import Items from 
Camera, Disk and URL options.

To apply an metadata template:
1. Select a group of images.
2. In the drop-down menu at the top of the Info 

Panel (Pencil icon), choose a metadata template 
(Figure 1.13). 

3. A dialog will appear showing the metadata that 
will be assigned by the template. You can turn 
some fields on or off to keep them from being 
applied to media items. Click the Apply button.

4. Click the checkmark icon to save the annota-
tions. In the confirmation dialog, select Apply 
to All items. Now all selected items have the an-
notations assigned by the template.

5. Tip: Choosing Remove Metadata Template will 
provide you with a dialog to remove tem-
plates from the drop-down menu. 

Drag-and-drop to Catalog Fields index
The Catalog Index is an alternative way to add 
metadata to your images, as opposed to entering 
annotations in the Info Panel. 

All IPTC and XMP standard fields in the Catalog 
Fields index support drag-and-drop. Other sup-
ported fields include: Catalog Sets, Date Finder  and 
Sample Color. Custom annotation fields also appear 
here (at the bottom of the Annotations group) and 
support drag-and-drop.

The drag-and-drop method significantly speeds 
up and simplifies the annotating process.

Annotating using the Catalog Fields index
1. Open the Organize Panel: Click on the  

Organize toolbar button or select Window › 
Display › Organize Panel.

2. Display annotation group: Reveal the de-
sired annotation group in the Catalog Fields 
index using the drop-down menu in the 
upper right hand corner of the panel. Expand 
the annotation group by clicking on the 
group name  (e.g. Date Finder, Keywords) to 
show available terms for that annotation. 

3. Add a term: If the annotation value does not 
exist, choose Edit › Add Terms. Type the name 

Figure 1.14: Select group of images, then drag-and-
drop them on to an annotation field (above) in the 
Catalog Fields index. If you switch over to the Info 
Panel (left), you will notice that same annotation is 
represented in the corresponding field for that image. 
Conversely, if you add metadata to an annotation in 
the Info Panel, it will also appear in the corresponding 
group in the Catalog Fields index.
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of the term and click OK.
4. Select a group of images, then drag-and-

drop them onto the new term (Figure 1.14). 
Associating an item with an annotation in a 
catalog does not affect the original file.

Batch removing annotations
You can remove the values from annotation fields 
from selected items by choosing Action › Clear An-
notations. 

In this dialog, you can choose to Clear All anno-
tations or Choose Fields (Figure 1.15) that you wish 
to remove. The latter reveals a list of annotations 
associated with all items, allowing you to select 
the fields to remove.

Sync annotations 
Adding annotation information to images in a 
MediaPro catalog does not embed (write) the 
information into the original file. The information 
only exists in the catalog.

To batch embed annotations into image files, 
choose Action › Sync Annotations (Figure 1.16). 
This command allows you to embed annotation 
information from the catalog into the original 
files. It also allows you to import annotations, 
by rescanning images for metadata added out-
side MediaPro with another application, such as 
Photoshop. 

The synchronization function only applies to 
annotations that are part of the IPTC, XMP, and 
QuickTime metadata standards.

Figure 1.15: Clear Annotations › Choose Fields (Action 
menu) reveals the annotation fields attached to item(s), 
allowing you to select the particular field(s) to remove. 

Figure 1.16: With this function, you can export (or write) 
metadata from the catalog to original files. You can also 
import metadata from original files.
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Figure 1.17 To turn on color profile matching in 
MediaPro, check Color Match in the Preferences › Media 
Rendering › Images dialog of the Edit menu (Mac: iView 
MediaPro menu).

Figure 1.18: Each Batch Profiles menu provides 
complete access to profiles defined by your operating 
system’s color management technology (ICM on 
Windows; ColorSync on Mac.) To learn more about color 
profiles, refer to your system’s Help documentation.

Online resources
• Apple ColorSync 

http://www.apple.com/colorsync/
• Microsoft ICM 

http://msdn.microsoft.com/library/
en-us/icm/icm_6ulv.asp

• International Color Consortium 
http://www.color.org/

Embedding ICC color profiles 
MediaPro supports ICC color profiles for image 
files in the JPEG, TIFF, PICT, PDF, and Adobe 
Photoshop formats. This enables MediaPro to pro-
vide color profile management from input source 
and iView catalog to proof and final printing.  

MediaPro provides you with color accurate dis-
play in all views – List, Thumbnail, Media, Lightbox 
and Slide Shows – using your operating system’s 
color management technology (ICM on Windows; 
ColorSync on Mac).

Batch assign profiles
1. Preferences: Turn on the color profile match-

ing preference by checking the Color match 
box (Figure 1.17) in the Preferences › Media 
Rendering › Images of the Edit menu (Mac: 
iView MediaPro menu).

2. Select items to batch: Select a group of 
images, then choose Action › Manage Color 
Profiles (Figure 1.18).  If this menu option is not 
available, it means you need to turn on the  
color profile matching preference.

3. Choose profiles: Select a color profile to 
embed for each type of image color space 
– RGB, CMYK, Grayscale.  This prevents you from 
embedding an inappropriate profile that could 
potentially ruin the image.  The options in each 
menu are defined by the operating system’s 
color management technology.  

4. Apply: Click OK. While embedding the profiles 
into the original files, MediaPro will create a 
new thumbnail for each image according to 
the new embedded color profile.

5. Batch remove: You can also batch remove 
profiles in this dialog by selecting Remove Em-
bedded Profile for each image color space.

6. Tip: For older iView MediaPro catalogs that 
contain thumbnails which are not color 
managed, select all items in the catalog and 
choose Action › Rebuild Items. This will create 
new thumbnails for all images according to 
the new embedded color profile and the set-
tings of the Size menu.
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Saving Batch edits: 
Click the Batch button 
to apply edits to all 
selected images. In the 
Batch dialog you can 
choose the file format, 
settings and metadata 
options before saving.

To activate Version Control, 
select a folder using the 
Setup dialog. Backup copies 
of version-controlled files 
will be saved in this folder. 
Make sure that you choose 
a separate backup folder for 
each catalog. 

Figure 1.19: Image Editor paletteImage editing 
iView MediaPro’s Image Editor offers powerful yet 
precise editing tools to crop, resize, transform and 
rotate images. As well, it has calibration filters that 
can enhance the color balance, levels, sharpness 
and brightness of your images.

The Image Editor functions apply only to image 
file formats (such as JPEG or TIFF) and will not work 
on movies or vector graphics. All filters and tools 
can be batched except for red-eye correction.

Batching with the Image Editor
1. Make a selection of images to batch.
2. Open the Image Editor by clicking the 

toolbar icon, or by selecting Window › Show 
Image Editor (Figure 1.19).

3. Choose a filter, such as Crop, from the Image 
Editor palette by clicking on the filter name in 
the list. In order to preview the filter effects of 
the Image Editor, MediaPro will automatically 
display the first image of your batch selection 
in Media View when a filter is selected.

4. Make your edits in the filter’s dialog, and 
click OK. Apply as many filters to the images 
as necessary. Use the Revert button to discard 
all changes and reload the original image. Use 
the Undo button to remove the effect of the 
last filter applied.

5. Batch apply and save edits: The image 
modifications made up to this point will not 
be saved until you click the Batch button in 
the Image Editor palette (Figure 1.19). This will 
launch a dialog to define file format, color 
depth and compression settings, and options 
for metadata preservation and backup of orig-
inal versions (Figure 1.20). Without any of these 
options checked, clicking Batch will apply your 
edits to all images and overwrite the existing 
(presumably original) files.

6. Preserving metadata: Saving image files 
through the Image Editor will remove embed-
ded digital photo metadata (EXIF) and color 
profiles (ICC) that may have existed in the 
original file, unless you check the options to 
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want to save your converted images as copies.
8. Click Convert and choose a folder on the 

desktop where your want the converted im-
ages to be saved.

Preserve color profiles and Preserve EXIF/GPS 
metadata. EXIF/GPS metadata can only be 
preserved in JPEG and TIFF file formats. IPTC 
and XMP annotations cannot be preserved in 
this saving function.

7. Preserving original versions: To store the 
original file in a folder of your choice, or in the 
Version Control folder, check the correspond-
ing option. The Version Control option will not 
be available unless you have defined a Version 
Control folder. To define a Version Control 
folder, click the Setup button in the lower right 
corner of the Image Editor palette (Figure 1.19). 
To learn more about Version Control, refer to 
the iView MediaPro manual.

Image conversion
Image conversions are ideal for creating copies for 
alternate purposes, such lo-res versions for email 
or Web distribution. Conversions are also good 
for resaving a file with different resolution, color 
space, format or compression settings.
 

Converting images
1. Make a selection of images.
2. Choose Make › Convert Image Files (Figure 

1.21). This function will convert most formats 
(except Raw).

3. Choose file format: Select from 11 different 
file formats such as JPEG, TIFF or PNG.

4. Define size and resolution: Select the output 
size and resolution of your images.

5. Define settings: Select color depth and com-
pression settings. The options in this dialog 
will correspond to the file format chosen. 

6. Options: Check the options to Preserve color 
profiles, Preserve EXIF/GPS metadata and 
Embed annotations to maintain embedded 
digital photo EXIF metadata, ICC color profiles 
and IPTC/XMP metadata that may exist in the 
original file. EXIF/GPS metadata can only be 
preserved in JPEG and TIFF file formats. 

7. Files: Check Replace original files to overwrite 
the existing files. Leave it unchecked if you 

Figure 1.20: The Save in versions folder option places 
the original version in the Version Control backup folder. 
Copy to another folder places the original in a folder of 
your choice.

Figure 1.21: Make › Convert Image Files
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MediaPro catalog, the edits will be reflected in 
updated thumbnails.  If you saved the images 
as copies to a new folder, they will need to be 
imported into the catalog.

• Compression and packaging: Assign ap-
plications such as WinZip or Allume Systems’ 
StuffIt, DropStuff or DropZip tools to com-
press items or create self-expanding files for 
Mac and Windows. This method is excellent 
for packaging a group of media files for email, 
backup or burning.

• CD/DVD Burning and backup: Assign any 
CD and DVD-burning application as a Helper 
and add files to a new disc image ready for 
burning. This action is similar to, but not ex-
actly the same as, iView MediaPro’s Backup 
command (see MediaPro manual).

• Scripts: See page 17 for instructions on how 
scripts can be used as Helper Applications. 

Helper applications
Your workflow will most likely involve performing 
some actions outside of the MediaPro working 
environment, such as advanced image editing 
with Adobe Photoshop. 

This is where iView MediaPro’s Open With Helper 
Application function comes in handy. Use Helper 
Applications to open a file with an application di-
rectly from MediaPro, thereby cutting extra steps 
out of your workflow.

Add a Helper
When first launched, MediaPro will automatically 
scan your computer for Helper Applications, but 
you may want to add or remove some later.
1. Choose Define Helper Applications in the 

toolbar’s drop-down menu (Figure 1.22) or in 
the contextual menu. This dialog will let you 
choose media editors, utilities or viewers so 
that you may quickly access them via the 
toolbar or through a contextual menu. 

2. Click Add in the Define Helper Applications  
dialog (Figure 1.23). Navigate to the desired  
application and select it. 

3. Click OK.  The Helper Application will be 
added to the list in alphabetical order. 

Open items with a Helper Application
1. Select a group of images.
2. Choose a Helper Application, such as Adobe 

Photoshop, in the toolbar menu (Figure 1.22), 
or through a contextual menu. Right-click 
(Mac: Ctrl-Click) to access a contextual menu.

3. The application will launch and open the 
batch selection of files.

How Helpers can assist you:
• Image editing: Assign an application such 
as Adobe Photoshop or Jasc Paint Shop Pro as 
a Helper for editing photos. Find images that 
you want to edit, open them in the Photoshop, 
make corrections to the images, then save 
them (over the existing files, or as a copy 
to a new folder). When you go back to your 

Figure 1.23:  To add a Helper, click Add and navigate to 
the desired application on the desktop and select it. 

Figure 1.22: After 
selecting images, you 
can execute an Open 
With Helper command 
two ways: 
In the toolbar’s icon 
pull-down menu 
(left), or through a 
contextual menu. 
Right-click (Mac: 
Control-Click)  
to access a   
contextual menu.



18    iView MediaPro Workflow Solutions

As you use iView MediaPro, you’ll find that you 
perform certain tasks over and over. Using scripts, 
you can automate some of these tasks. A script is a 
series of commands that tells MediaPro and other 
applications what to do.

MediaPro can be scripted to perform basic func-
tions such as annotate, convert, organize and print. 
Or it can be scripted to perform a complex series 
of tasks such as: copy images from a media card to 
a new folder on your computer, build a MediaPro 
catalog, assign and embed annotations in the im-
ages, and save the catalog to the same folder.

Scripts can work in collaboration with other ap-
plications that are scriptable. Using scripts, MediaPro 
can be easily integrated with 3rd-party applications, 
Web services or database systems to perform work-
flow automation. 

Scripting 
Windows: MediaPro supports Visual Basic Script 
and JavaScript automation on Windows operating 
systems. Once you create a script, you can attach 
it to the application for access through the Scripts 
menu. For instructions on creating scripts, refer to 
the scripting documentation, Windows Scripting 
Guide, included with MediaPro. It is located at:

• C:\Program Files\iView MediaPro\ 
Documents\
Mac: MediaPro supports AppleScript automation 

on the OS X operating system. Once you create a 
script, you can attach it to the application for access 
through the AppleScript menu (Figure 2.1). To get 
started with scripting, review MediaPro’s scripting 
dictionary and the sample scripts included with 
MediaPro. They are located at:

• /Applications/iView MediaPro/ 
Documentation/Examples AppleScript 
Please note that MediaPro 3 introduced a num-

ber of changes to the AppleScript dictionary, so if 
you are using an older script, test it first. 

To create a script, use a text editor or a special 
application such as the Script Editor, which is in-

cluded with Mac OS X. Test your existing scripts 
to ensure proper functionality before using them 
with cataloged media.

Attaching scripts to MediaPro
The iView MediaPro installation creates a Plug-ins 
folder containing files that are important to the 
application’s functionality. MediaPro also creates a 
user-defined Plug-ins folder for you to customize 
or install additional functionality, such as scripts, 
HTML templates, print templates, favorites lists,  
and media importers. 

The MediaPro Scripts menu displays all scripts 
from both Plug-ins › Scripts folders. When install-
ing custom scripts, place them inside the user-
defined Plug-ins folder, and not the application 
Plug-ins folder. This way you will not lose your 
custom settings and plug-ins when upgrading 
to future versions of MediaPro.

Windows: The user-defined Plug-ins folder is 
located in one of the following locations:

• C:\Documents and Settings\username\ 
Application Data\iView\Plug-ins

• C:\Documents and Settings\All Users\ 
Application Data\iView\Plug-ins
On some Windows operating systems the Ap-

plication Data folder may be hidden. To display 
hidden files and folders on Windows XP:
1. Click Start and then click Control Panel.

Automate tasks and workflow

Figure 2.1: 
You can add 
scripts to the 
AppleScript menu
(Mac) by placing 
them in the user-
defined Plug-ins › 
Scripts folder.

Custom scripts 
appear at the 
bottom of the 
Scripts menu.
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2. Click Appearance and Themes and then click 
Folder Options.

3. On the View tab, under Hidden files and folders, 
click Show hidden files and folders. Hidden files 
and folders will appear dimmed.
Mac: The user-defined Plug-ins folder is located 

in one of the following locations:
OS X: Any of the three locations:
• ~User/Library/Application Support/iView/
Plug-ins

• /Library/Application Support/iView/Plug-ins
• Network/Library/Application Support/iView/
Plug-ins

Scripts for importing
MediaPro provides two scripts for importing cata-
logs created by other digital photo management 
applications:

• iPhoto (Mac): Choose iView MediaPro › Get-
ting Started and select Import iPhoto Library. 
MediaPro will automatically find the iPhoto li-
brary for the active user and import all original 
photos into a new catalog. This feature works 
with iPhoto 2 and 4.

• Adobe Photoshop Album (Windows): Se-
lect Scripts › Import › Import from Adobe 
Photoshop Album. MediaPro will find the 
Photoshop Album catalog for the active user 
and import all original photos into a new cata-
log. This script works with Photoshop Album 
1 and 2.

Folder actions (Mac only)
A folder action is an AppleScript that you attach to 
a folder. Triggered by certain events, such as when 
you open or close the folder or add an item to it, 
the folder action script performs some function.

The function could be to upload (FTP) files to a 
Web server, copy files to a backup hard drive or to 
batch print files to a network printer. The function 
is determined by the attached script.

Folder actions are powerful automation tools 
when combined with MediaPro’s Catalog Folders 
tool (Organize Panel). A folder action will be acti-

vated by dragging-and-dropping images onto the 
relevant folder in the Catalog Folders pane. Like-
wise, you could move or duplicate files to a folder 
that has an attached script using the Action › Trans-
fer To Folder function.

Scripts as Helper Applications
Helper Applications are other programs installed 
on your computer that you can use to edit, play, 
view or compress catalog items. Using Helpers 
keeps you from having to launch an application, 
navigate the desktop and locate a file. 

Some scripts, depending on how they are cre-
ated, are viewed by the operating system as an 
application and can be defined in MediaPro as a 
Helper (see pg. 17 for instructions on defining Help-
ers Applications).

Droplets created by Photoshop or Image-Ready 
can be integrated into your workflow by assigning 
them as Helper Applications (Figure 2.2). A Rotate 
90-degree clockwise Photoshop droplet or Make 
JPEG (quality 60) ImageReady compression droplet 
will save you quite a bit of time when used as a 
MediaPro Helper. Any AppleScript applet, scriplet 
or droplet that has been saved as an executable 
can be defined in MediaPro as a Helper.

Sharing scripts
The iView customer forum has several topic areas 
dedicated to scripting solutions. MediaPro’s com-
munity of customers use this forum to share 
answers to common questions, advanced tech-
niques and scripts they have developed.
Online at: www.iview-multimedia.com/forum/

Figure 2.2: Examples of droplets created by Adobe 
ImageReady, Photoshop and AppleScript Editor (Mac) 
which can be defined in MediaPro as a Helper.
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Option sets
Several complex functions in MediaPro offer the 
ability to save a set of options for easy recall and 
repeat use. These settings are stored in the Options 
menu of a function’s dialog box (Figure 2.3). Saved 
options can be incorporated in scripts. 

The following functions can store Options:
• Find: Save and recall simple or complex bool-
ean (and/or) search strings.

• Batch Rename: Save and recall various meth-
ods of renaming your media files.

• View Options: Store the display options 
(Themes) for text, color and metadata of the 
List, Thumbnail and Media Views. 

• HTML Gallery: Store variations on theme set-
tings for different clients or projects. The Site 
Title is not stored with an option set.

• File Conversion (Images): Good for saving 
conversions with a specific purpose, such as 
compression for Web or client options.

• Text Table: Save and recall various metadata 
groupings that you wish to export (Figure 2.3).

• PDF Maker: Store page layout styles for the 
production of high-res PDFs. 

Save an option set
1. Ensure you have all the function’s dialog op-

tions set appropriately.
2. Select Save from the option set menu. 
3. Type the name of the option set, and click OK. 

Option sets menus are listed alphabetically. If 
you want to force a particular option set to ap-
pear at the top the list, then put a blank space 
as the first character of the name.

4. Tip: There are currently no methods for renam-
ing an option set. If you want to change the 
name, you must save the option set a second 
time using a different name, the remove the 
old one from the list.

Remove an option set
1. Select Remove from the option set menu.
2. In the dialog, select an option set and click the 

Remove button.

Share an option set
You may want to install option sets on other com-
puters in a workgroup or share them with other 
MediaPro users. Option sets are small custom files 
and are easy to copy, share and install.
1. Locate the user-defined Plug-ins › Option Sets 

folder. See page 18 for the path to this folder.
2. There are several folders of option sets:  

BREN: Batch Rename; CLGE: PDF Maker; INFL: 
Info Panel Configuration; IMGC, SNDC and 
MOVC: File Conversion; HTML: HTML Gallery; 
TEXT: Text Table; VIEW: Saved Themes.  
Find option sets cannot be shared.

3. Copy the desired option set to the desktop 
and distribute it to whomever you wish. The 
recipient must place the option set in the cor-
rect corresponding option set folder.

4. Tip: It is important that the recipient/user of 
your shared option set has the same version 
of MediaPro as you. Also, when sharing HTML 
Gallery option sets, your recipient will need to 
have the relevant themes installed for the op-
tion set to function properly.

Figure 2.3: Option sets 
are good for saving 
and recalling a large 
group of settings. 
Option menus are 
typically located in the 
lower left of a dialog.



Optimize your photo management workflow   21

Auto-importing images
MediaPro offers advanced folder watching to 
monitor all folders on a hard drive and local net-
work which contain cataloged media. When new 
media appears in a watched folder, it can be man-
ually or automatically imported to the catalog.

This is useful for a workflow in which:
• Images are being batch scanned and saved to 
a particular folder.

• A folder action is automatically downloading 
images off other computers or the Internet.

• Several users are contributing images to a 
shared network folder.

To turn on folder watching
1. Show Organize Panel by clicking the Or-

ganize toolbar button, or choose Window › 
Display › Organize Panel. This will reveal the 
Catalog Folders panel (Figure 2.4). 

2. To enable folder watching, select an op-
tion from the catalog Folder Watching menu 
— either Update Folders: Every minute or Every 
5 minutes. 

3. Update folder: MediaPro will alert you when 
new images have been added to any folder 
by showing by a blue arrow on the folder icon. 
To import these new images directly to your 
catalog, select Update Folder Now from the 
individual folder’s drop-down menu.

4. Auto-update takes folder watching to the next 
level by automatically importing from selected 
folders when new images are added. To enable 
this feature, select Switch Auto-Update On in the 
menu of the individual folder that you want to 
be auto-updated. When new images are added 
to that folder or any sub-folder, MediaPro will 
automatically import those images into to your 
catalog. New images will be added to the end 
of the catalog. Auto-update folders are shown 
in green. Select Switch Auto-Update Off to turn 
off the auto-update feature, but maintain folder 
watching.

5. To turn off catalog-wide folder watching, 
select Never from the catalog Folder Watching 
menu. 

Folder Watching menu

Green folders 
indicate auto-
update is on.

Blue arrows 
indicate 
that new, 
uncataloged 
images are 
in this folder. 
Select Update 
Folder Now to 
import these 
new items.

To expand  
all folders, 
Alt+Click (Mac: 
Option+Click) 
on the volume 
arrow.

Green indicates Folder Watching is on

Figure 2.4: Click the Organize toolbar button to show/hide the Catalog Folders panel (Window menu).

Individual folder menu : Reveal this 
menu by right-clicking (Mac: Option-
Clicking on the folder name.

Click the dot next to any folder to 
show only items in that folder in the 
media viewing area.
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to create thumbnails, color profile management 
will add some additional time to the process. For 
the fastest import settings, make sure Color match 
is not checked in the Preferences › Media Render-
ing › Images dialog. 

Raw rendering preferences: Canon, Kodak and 
Nikon Raw image files may contain a large preview 
that is suitable for viewing and renders much faster 
than decoding the Raw data. If you check Use em-
bedded preview in the Preferences › Media Render-
ing › Raw dialog this will speed up the importing 
and media display of Raw files (Figure 2.6). For other 
supported Raw file formats, such as Sony, Fuji and 
Minolta, MediaPro automatically uses the embed-
ded preview.

Digital camera importing: When importing and 
cataloguing images directly from a digital camera 
over a USB 1.0 connection, most of the settings 
mentioned here will not have much of an effect 
because the speed of importing is governed by the 
time it takes images to be copied from your camera 
to the hard drive. However,  Firewire and USB 2.0 
connections provide much faster transfer rates and 
these settings will improve importing speeds. 

Fast image importing
The amount of time MediaPro takes to import 
media into a catalog will vary based on your com-
puter’s operating system and overall speed. 

For images, the import speed is also governed 
by the following preferences: embedded thumb-
nails, color profile matching, and digital camera 
Raw previews. 

This section covers the optimum settings for 
the fast importing of digital images:

• On: Use built-in thumbnails
• Off: Use Color match
• On: Use embedded preview for Raw

Thumbnail preferences: Some applications, 
such as Adobe Photoshop, embed a thumbnail 
preview into media files. Digital cameras do this as 
well. These built-in thumbnails are typically small, 
highly-compressed and low quality. 

During import, MediaPro reads and displays 
built-in thumbnails if the Use built-in thumbnails 
box is checked in the Edit › Thumbnails & Previews 
dialog (Figure 2.5). Importing with this option on 
is very fast because MediaPro simply reads and 
displays the built-in thumbnail preview. 

Turning this option off will instruct MediaPro 
to create its own thumbnails, which are generally 
higher in quality (and color managed, if the option 
is on). But because MediaPro needs to render the 
entire image in order to create a thumbnail, this 
can slow down the import process. 

When you are using a laptop and wish to con-
serve battery power, you would want to use built-in 
thumbnails, which make the import process much 
faster. If you want to improve the quality of the 
thumbnails later, when you have a mainline power 
supply, select all the cataloged items and choose 
Action › Rebuild Item. This will instruct MediaPro to 
create high-quality thumbnails for all items.

The amount of time it takes to rebuild items will 
vary depending on the size of the original media 
file. For example, it will take longer for MediaPro 
to create a thumbnail of a 25 MB TIFF than it will 
for a 3 MB digital camera JPEG. 

Color profile preferences: When MediaPro has 

Figure 2.5: In Edit › Thumbnails & Previews turn on the 
Use built-in thumbnails option.

Figure 2.6: Preferences › Media Rendering › Raw
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A good way to increase your efficiency and pro-
ductivity with MediaPro is to customize the work-
space and tailor it to your workflow needs.

Themes - View appearance 
Each view of MediaPro (List, Thumbnail and Media) 
can be customized by using the View Options pal-
ette. You can choose which metadata to display, the 
background color, as well as the font, size, and color 
of display text. The View Options palette can be ac-
cessed by choosing Window › Show View Options or 
clicking on the View Options icon in the toolbar.

In addition to the display, View Options also apply 
to some export functions, such as printing, contact 
sheets and the default HTML gallery theme. 

Each view has its own options. For example, 
changing the text and display options in List View 
will not change the options in Media View.  Visual 
preferences for all three views can now be stored 
as a theme, using the Save function of the View Op-
tions toolbar icon.

Adjust font and color options
In the first section of the View Options palette:

• Font and Size: Use the drop-down menus to 
select a font and preset point size. 

• Background defines the background color of 
the media viewing area.

• Text Foreground defines the color of text, field 
labels and the media frame.

• Text Background defines the color bar that 
appears behind text. To make this bar appear 
transparent, make this color the same as the 
background color in order.

Set display options: List View
• Frame media adds a one pixel border around 
thumbnails. The color of this frame is defined 
by the Text Foreground color option.

• Use generic icons will change a rendered icon 
to a generic icon.

Customizing the MediaPro workspace

Set display options: Thumbnail View
• Field labels puts the name of the field next to 
the displayed text of that field.

• Frame media adds a one pixel border around 
thumbnails. The color of this frame is defined 
by the Text Foreground color option.

• Center text aligns field text centered. 
• Show scale displays the thumbnail size as a 
percentage of the original media size. 

• Aspect ratio adjusts the proportion of all 
thumbnail containers. These options are valu-
able for saving space in the media viewing 
area, depending on the shape of most media 
in your catalog (Normal [Square], 3:4 Land-
scape, 4:3 Portrait). 

• Margin offers options for a stylized border around 
all thumbnails. Blank adds a small amount of 
white space around thumbnails; Shadow adds 
a drop-shadow to thumbnails; Frame adds a re-
cessed frame around thumbnails.

Set display options: Media View
• Field labels puts the name of the field next to 
the displayed text of that field.

• Center text aligns field text centered. 
• Histogram will display a graph showing the 
relative distribution of Red, Green and Blue 
pixel densities in an image. It shows the num-
ber of pixels with high density on the left 
(darker colors) and low density on the right 
(lighter colors). 

Size menuZoomFigure 3.1
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To adjust the number 
of lines used to display 
a field, click the up and 
down arrows. 

Displays number of 
fields shown out of the 
maximum (10).

Background

Text 
Foreground

Text 
Background

Field labels

Show scaleFrame media

Display Options Font & Color Options

Use generic icons (List View)

To adjust the style of the 
font display (Bold, Italic, 
etc.), make a selection from 
the options in the font 
Style menu.

To make a field display in 
a view, click the name to 
place a check mark next 
to the field name. Click 
the name again to hide 
this field and check mark.

To make your current 
settings the default for 
new catalogs, click Save as 
Default.

Save themes: 
For repeat use of your 
settings, save them using 
the Options menu or 
using the View Options 
toolbar icon drop-down 
menu. The settings for 
all three views are stored 
when you save a theme. 

View Options palette

Display the star rating and 
color label assigned to 
each media item.
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Adjust media size in views
To define the display size of previews in List and 
Thumbnail View, select an option from the Size 
menu in the far right side of the Header bar (Figure 
3.1).  Size of media can also be defined in the Display 
Options section of the View Options palette.

List View: Choose from Small (16 px) and Large 
(32 px) options. The View Options palette has an 
option to switch from rendered icons to generic.

Thumbnail View: Choose from a range of 
thumbnail sizes from 120 to 640 pixels. 

Media View: Options include: Actual Size, 
Scale to Fit, Fit Width, Fit Height, Pin Larger Side, Pin 
Smaller Side, Tile, and a selection of percentages. 
When an image doesn’t fit entirely inside the win-
dow, the cursor changes to a hand. Use the hand 
to drag the image around in the viewing area.  

In all views, the Zoom buttons (plus and minus 
icons next to the Size menu) increase or reduce the 
size of the thumbnails or media.

Add or remove displayed fields
Located in the third section of the View Options 
palette. A maximum of 10 fields can be displayed 
in each view. 
1. To add a field to a view, click its name in the 

field list area. This will make a check mark ap-
pear by the name. To remove a field, click it 
again and the check mark will disappear.

2. The order in which fields are displayed is 
determined by the order in which they are 
turned on in the View Options palette.

3. Change the number of lines displayed for each 
field by clicking the up/down arrows on any 
active field. This is useful for fields with longer 
amounts of text, such as Caption or Paths.

4. Font styles, such as Bold, Italic, and Underline, 
are optional for each field and can be selected 
in the Style menu for each field name. Multiple 
styles can be applied at the same time.
See Figure 3.2 for an example of a customized 

Thumbnail View.

Figure 3.2: Thumbnail View displaying image properties, custom colors, fonts, 3:4 aspect ratio, and a frame margin.
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Info Panel and Catalog Fields lists
Some images in your catalogs will have large 
amounts of metadata displayed in the Info Panel. 
To view all of this information, you can scroll up 
and down the Info Panel. However, this task may 
become too cumbersome or repetitive, especially 
when scrolling past empty fields or metadata 
groups that are irrelevant to your workflow.

The same can be said of the Catalog Index in 
the Organize Panel, which is used for sorting and 
annotating images.

As a solution, you can selectively display the 
most relevant fields or groups of metadata in the 
Info Panel and Catalog Index using the List Con-
figuration menu (Figure 3.3). 

The state of the Info Panel and Catalog Field 
index lists is unique for each catalog and is main-
tained when saving and closing a catalog.

The List Configuration menu also has the op-
tion of storing a default state of hidden and shown 
fields, which you can define. 

This default can be useful for workflows that 
focus on a specific subset of metadata. For exam-
ple, your annotation workflow may only require 
data entry in eight of the IPTC annotation fields, 
as well as Keywords. In this case, you can choose to 
store a default that shows only these fields in the 
Info Panel.

Set List Configuration default
1. Define shown/hidden fields: Select Show/

Hide Fields in the list configuration menu 
(Figure 3.3). Check the box next to the field to 
show it; unchecked fields are hidden.

2. Save configuration: Choose Save as Default 
in the List Configuration menu to store the  
current configuration as the default which  
can be loaded into existing or new catalog. 
This configuration is automatically applied to 
new catalogs. 

3. Load configuration:  Open an existing 
catalog or create a new catalog. Select Load 
Default in the List Configuration menu to load 
previously configured settings.

Figure 3.3: Use the List Configuration menu 
to show or hide properties, annotations or 
groups. Save as Default stores the current Info 
Panel configuration as the default which can 
be loaded into existing or new catalogs.

Catalog Field index - List Configuration menu
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Custom annotation fields
iView MediaPro supports up to 16 custom anno-
tation fields. These fields are useful for creating 
additional metadata associated with a specific 
project, client or storage location. 

To add or remove custom fields, choose Edit 
› Custom Fields (Figure 3.4). If these custom fields 
are necessary for all your catalogs, click the Save as 
Default button in the lower left and these custom 
fields will appear in all new catalogs.

Once defined, custom annotation fields can be 
used in various sorting and searching functions 
of MediaPro, such as: the Info Panel’s Annotations 
data entry fields; the Catalog Index’s Annotation 
Organizer; the Sort toolbar menu; View Options to 
be displayed in List, Thumbnail and Media Views; 
and as fields to be searched in the Find dialog.

When you move images between catalogs, 
custom fields are automatically adjusted between 
the catalogs. If two catalogs contain more than 16 
unique custom fields, the first 16 fields alphabeti-
cally will be retained.

Figure 3.4: MediaPro supports up to 16 custom 
annotation fields. To add or remove custom fields 
choose Edit › Custom Fields. These fields will appear as 
part of the Annotations group in various functions.

Figure 3.5: Once defined, Custom Annotation Fields can 
be used in various sorting and searching functions of 
MediaPro, such as the Info Panel (A), Catalog Index (B), 
Sort toolbar menu, View Options and the Find dialog (C).

To make custom fields appear in all new catalogs, click 
the Save as Default button.

A

B

C
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Reviewing and marking media

Once you have imported a collection of media into 
a catalog, you will likely want to review and clas-
sify the media. For example, after importing images 
from a shoot, photographers typically edit images, 
marking their favorites and unusable ones. 

To assist in this process, MediaPro provides two 
methods of classifying and ranking media: star rat-
ings and color labels. Using keyboard commands, 
labels and ratings can be easily assigned in any 
view, the lightbox and during slide shows.

Rating media
Star ratings provide a ranking system for items in 
your catalogs.  You can now rank your media from 
one to five stars, or no stars.

Assign a rating
Once you have selected one or more items, you 
can add a rating three ways: 
1. Choosing a star rating from the Rate Media 

drop-down menu in the toolbar (Figure 4.1), or 
in the contextual menu.

2. Pressing Alt + a number, 1-5 (Mac: Ctrl+1-5). 
This will apply the associated rating.

3. Drag-and-drop items onto the Rating section of 
the Catalog Field index of the Organize Panel 
(Figure 4.2). 

Remove ratings
Select one or more items and: 
1. Choose None from the Rate Media drop-down 

menu in the toolbar, or from the contextual 
menu in any view. 

2. Select an item and press Alt + the number 
zero (0). On Macs, press Ctrl+0.

Show files associated with a ratings
Select one or more items and: 
1. Click a rating in the Rating section of the Catalog 

Field index of the Organize Panel (Figure 4.2). 
2. Select Show Rated (Find menu) and choose a 

rating value of items you want to be displayed. 

Figure 4.1: Assign label toolbar icon, and drop-down 
menu and the Rate media toolbar icon, and drop-down 
menu. Use any of the associated numbers to apply a 
label to a file in your catalog while in any view, even 
slide shows. Use Alt+1-5 (Mac: Ctrl+1-5) to apply a 
rating to a file in your catalog while in any view, such as 
Thumbnail View, Media View, Lightbox and Slide Show.

Figure 4.2: Assign or sort items with labels or ratings. 
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Ratings as annotations
Ratings in MediaPro are mapped to Adobe’s XMP 
standard for ratings (Figure 4.3). When annotations 
for images in a catalog are synchronized (written) to 
the original files, all ratings will be written into the 
files. If you open the media in Adobe Bridge, the star 
ratings will be displayed. Likewise, if you assign a rat-
ing in Adobe Bridge,  the star rating will be reflected 
in your MediaPro catalog.

Color labels 
Labels provide a visual identification and classifi-
cation system for items in your catalogs. 

A color label can be used to: mark favorite 
items; mark items to delete, archive or convert; 
or to track items that are in different stages of a 
workflow (Figure 4.4 - A). 

After you label your items, you can quickly sort 
the catalog using  the Label section of the Catalog 
Field index in the Organize Panel.

A label can also be used as a temporary method 
of marking items that will be later assigned a par-
ticular annotation. After assigning the annotation, 
the labels can be cleared from the images.

To accommodate your desired method of mark-
ing items, the colors and names of labels can be 
customized in MediaPro as a global application 
preference. Because this customization is global, 
shared catalogs will inherit the label names and 
colors of the user that is opening the catalog and 
not the preferences of the person who created 
the catalog.

Customize labels
1. Open Preferences by choosing Edit › Prefer-

ences › Labels (Windows) or iView MediaPro › 
Preferences › Labels (Mac OS X).

2. Click the color swatch you wish to change. 
This will launch the operating system’s color 
picker, where you can define a custom color. 
Colors can be adjusted for aesthetic preference 
or to better match the tone or contrast of a par-
ticular view background color (Figure 4.4 - B).  
Colors can also be matched to a labelling 

Named to match the IPTC 
Urgency values.

Lighter palette designed 
for dark backgrounds.

Figure 4.4: Three variations on customized colors and 
names to assist a workflow.

Figure 4.3: Ratings marked in Adobe Bridge are 
viewable in your MediaPro catalog. If you assign a rating 
in MediaPro and synchronize (write) it to the file, it will 
conversely be shown in Adobe Bridge (above).

A

B C
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scheme in another application or environ-
ment, such as Mac OS X system color labels. 

3. Select any label text and type a new name. 
Customizing a label name helps to remember  
the label’s purpose or definition. 

4. Tip: Custom names used for labels become 
indexed as search terms for associated items in 
iView MediaPro.  For example, if a label is named 
“Client Picks,” then any free-form text search in 
the MediaPro toolbar for the word “client” will 
return images assigned with that color label.

Assign a label
Once you have selected one or more items, you 
can add a label three ways: 
1. Choosing a color from the Assign Label drop-

down menu in the toolbar (Figure 4.1), or in 
the contextual menu.

2. Pressing a number key (1 through 9). This will 
apply the associated color (e.g. 1 = Red).

3. Drag-and-drop items onto the Label sections 
of the Catalog Index (Figure 4.2). 

Remove labels
Select one or more items and: 
1. Choose None from the Assign Label drop-

down menu in the toolbar, or from the contex-
tual menu in any view (Figure 4.1). 

2. Select an item and press the number zero (0).

Show files associated with a label
Select one or more items and: 
1. Click a color label in the Labels sections of the 

Catalog Index (Figure 4.2). 
2. Select Show Labelled in the Find menu and 

choose a label value of items you want to be 
displayed. Labelled files can also be sorted 
during slide shows. Use the Show Labelled 
drop-down menu in the Slide Show controller.

Methods for using labels
A label can stand for anything you want — favor-
ites, items to discard or items that are in different 
stages of the editing process. 

One popular method of using labels is to mark 
favorite selects (and items to delete) after a photo 
shoot. After importing images into a catalog, 
launch a slide show or the Lightbox. As you re-
view the images, use one label to mark the best, 
and another label to mark images that are out-of-
focus and unusable. This can be done during the 
slide show (or in any view) by pressing the label’s 
corresponding number key.

Afterward, you can use the Label section of the 
Catalog Field index (Organize Panel) to show only 
the best images from a shoot in your catalog.

Labels as annotations
Labels in MediaPro are mapped to the IPTC stan-
dard’s Urgency annotation field. When annotations 
for images in a catalog are synchronized (written) 
to the original files, all images tagged with a label 
will have the corresponding label number (1-9) 
written into the Urgency field. For Photoshop CS 
users, these are the same values used in the Ur-
gency field of the File › File Info › Origin panel.

Even if you have customized the colors and names 
of labels, the values 1-9 are written into the Urgency 
field in order to comply with the IPTC annotation 
standards. If the Urgency field is important to your 
workflow, you might customize the label names to 
match the standard (Figure 4.4 -C).

Figure 4.5: Labels can now be edited inline by clicking 
on the color label field in any view.
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Lightbox
The Lightbox mode is the best way to view an 
image or compare up to four different images at 
once.  To use the Lightbox mode, select between 
one and four images and choose Lightbox from 
the View menu, or use the keyboard shortcut,  
Alt+Enter (Mac: Command + / ).

When you first launch the Lightbox the Help 
menu appears showing the navigation and key-
board shortcuts. While in Lightbox mode, use right 
click (Mac: Option+Click) to show the contextual 
options menu that includes the option to show  
this initial help menu again.

The default display of the Lightbox is the cho-
sen number of images shown in a Grid layout (2x2) 
with a toolbar for each image. The toolbar shows 

the color label, filename, dimensions and scal-
ing percentage of each image (see figure below). 
The toolbar also displays buttons for trashing or  
removing images, rotation and display size.

Figure 4.6: MediaPro’s Lightbox mode is the ideal tool for viewing and comparing images.

Figure 4.7: Choose between Grid (top), Landscape 
(above) and Portrait modes for image display.

Label, rating 
drop-down menus

Media Info: Filename, Dimensions, 
Scale Percentage

Remove/Trash Rotate Size
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When you have more than one image showing 
in the Lightbox, try using the Landscape, Portrait 
and Grid layouts (hotkeys L, P and G respectively) 
to use your monitor space as efficiently as pos-
sible (Figure 4.7).  Which layout works best for you 
depends on the orientation of your images, how 
many image you view at once and wether you 
want to see the toolbar and/or the histogram. 
You may wish to hide the toolbar to maximize the 
viewing area for each image (hotkey T).

The trash/remove button gives you two op-
tions: Move to Trash and Remove From Catalog.  The 
first option removes the image from the catalog 
and moves the original image file to the trash or 
recycle bin.  Be careful when using this option. Do 
not use this unless you are sure you want to de-
lete the original file.  The second option removes 
the image from the MediaPro catalog and leaves 
the original file untouched.

Marking images
Color labels are set using the normal label hotkeys 
(1-9, 0 [zero] to remove a label).  When more than 
one image is shown the color label is applied to 
the image that the cursor is currently over.  These 
are the same labels used throughout MediaPro.  

You can also mark images using star ratings. 
Use the shortcuts Alt+1-5 (Mac: Ctrl+ 1-5) to set 
the rating. See page 29 for more about labels; page 
28 for ratings.

Adjusting image size
The toolbar’s size menu (magnify symbol) offers  
several options to define the scale of images dis-
played within each Lightbox cell. These size op-
tions are the same as MediaPro’s Slide Show and 
Media View modes. 

To zoom in on an image, use the + (plus) and 
- (minus) hotkeys. If Scroll Lock is on, all images 
will increase and decrease by the same magnifica-
tion. If Scroll Lock is off, only the scale of the active 
image will be adjusted.

Scroll, Scroll Lock and Zoom
When an image is bigger than the window it is 
in,  your cursor will turn into a hand ( ) which can 
move the image by dragging (clicking and hold-
ing while moving the mouse).  

When more than one image is shown in the 
Lightbox, all shown images will be moved simulta-
neously while Scroll Lock (hotkey S) is on.  If any of 
the images do not move when scrolling in this way 
it is probably because they fit the current window 
and there is no more of the image to show.

When Scroll Lock is turned off, only the image 
under the cursor is moved by dragging. Scroll 
Lock is useful when examining an important area 
of similar images.

By zooming in and scrolling to the part of an 
image you are interested in, the other shown im-
ages will show the same portion of the image.

If the images are not absolutely identical you 

Figure 4.8: Right-click (Mac: Option-Click) on any image to display the Lightbox Contextual Options menu.
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may need to toggle Scroll Lock off and move the 
image individually.  Remembering the hotkey (S) 
for the Scroll Lock makes viewing similar images 
much faster.

Next and Previous images
The right or down arrow key changes the image 
in the Lightbox to the next one in the catalog.  The 
up or left arrow key changes to the previous one.  

When there is more than one image onscreen, 
the image that is changed is the one the cursor is 
currently over.  When changing the image using 
the cursor keys, the current zoom and scroll posi-
tions are maintained to make it easier to examine 
the same point on similar images.

Pixel Magnifier
The Pixel magnifier is a floating palette that shows 
a close up of the image area underneath the cur-
sor (Figure 4.9). To turn on the pixel magnifier, use 
the M hotkey.  The pixel magnifier can be quicker 
than zooming and scrolling, particularly when 
there is more than one area in any particular 
image that you need to examine closely.

The slider controls how far the magnifier zooms 

in.  There are four settings from the least magni-
fied at the bottom to the most, at the top.  The 
slider snaps to one of these four settings. 

The pixel magnifier also shows the X/Y coor-
dinates of the cursor (highlighted by a green 
square), as well as the RGB color values.

Using the Histogram and  
Exposure warnings to judge images
When viewing images you may wish to view a His-
togram and Exposure warnings for each image, use 
hotkey H to show/hide the histogram and W for 
the exposure warnings (Figure 4.10).

A histogram is a graph showing the relative dis-
tribution of Red, Green and Blue pixel densities in 
an image. It shows the number of pixels with high 
density on the left (darker colors) and low density 
on the right (lighter colors). Its purpose is to show 
the distribution of tone throughout an image. 

For example, an image with no shadows will 
have a histogram with a valley on the left; a histo-
gram with no highlights will have a valley on the 
right. Dark shadows will be seen as a peak of all 
three colors to the left and bright highlights a peak 
of all three colors of the right. 

Figure 4.9: The Pixel magnifier shows a close up of the image area underneath the cursor.

Use slider to 
adjust zoom.

RGB color values and X/Y coordinates apply to this green square. 
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The exposure warnings will show areas of pos-
sible over exposure in an image as solid red rep-
resents, under exposure in solid blue.  Both over 
exposure and under exposure are areas of an 
image where detail may be lost due to too much 
or too little light being captured.  

Exposure warnings only indicate areas of an 
image that might be over or under exposed  For 
example, these warning areas may be of a very 
dark or light object that simply appears as it 
should or parts of an image may intentionally be 
very dark or light.

If we consider the histogram for the image A 
(Figure 4.10), it is biased towards the right, the green 
and blue colors reach the top of the chart at the ex-

treme right side.  We could consider that this is an 
image of a intentionally very bright summer scene, 
so the strong sunlight, blue sky and aqua marine 
pool are just reflected in the histogram.

Examining the exposure warnings for this 
image (Figure 4.10 - A), as we might expect, the 
left the whole sky is colored red to warn us of 
possible over exposure. There is no detail in the 
sky in this image because the sky has been over 
exposed. The person is the focus of this image and 
the band of white sky works quite well with the 
other two horizontal bands created by the sea 
and the pool.  So, for this image, whether it would 
be improved by editing is a subjective.

So the histogram and exposure warnings simply 

A

B

B

A

Original images, with no exposure warnings.

Figure 4.10: Lightbox showing exposure warnings and histograms.
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gives us an indication of areas we might want to 
consider improving through editing.

But lets compare this with image B (Figure 4.10). 
It shows a similar pattern of the red, green and 
blue with both images showing red towards the 
middle with lots of green and then blue as we go 
to the light side of the histogram.  

The histogram, for the image on the right, is 
still biased towards the right but not to the same 
degree as the other image, the pixels are spread 
across the mid section of the histogram not just 
the very light side. With a more balanced histo-
gram we would expect to see a wider range of 
tones. Both the pool and the sky are deeper in 
tone and there is some detail in the sky.

Looking at the exposure warnings, a smaller 
area of the sky is red and this is a broken up area, 
rather than the solid area in the left hand picture. 
Certainly, from the point of view of the sky, the 
image on the right is better. There are solid areas 
of red on the side of the models face, indicating 
over exposure, but this is direct sunlight and since 
the subject of the image is sunbathing this works 
well. Part of the models hair shows as under ex-

posed but again that is not necessarily an indica-
tion of a problem.

One opinion may be that the image on the left 
would benefit from editing and the image on the 
right less so. A balanced histogram is normally 
considered better although there is no ideal his-
togram.  Areas shown as possible over and under 
exposure are things to consider when viewing 
your images. 

In the end, whether an image is good or can 
be improved is subjective. The histogram and 
exposure warnings should help you make your 
decision. Knowledge of digital image editing 
techniques will help you know what to look for 
when using both these tools. Please read the 
documentation provided with your image edit-
ing software for more information.

Adjusting Lightbox exposure warnings
You may want to adjust the sensitivity of exposure 
warnings. To define the under and over exposure 
values that trigger red and blue warnings, see the 
Lightbox Warnings section of the Preferences › 
Media Rendering › Images dialog.

Red warnings indicate potential over exposure. Blue warnings indicate potential under exposure.

HistogramFigure 4.11
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