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Digital photo management 
using iView MediaPro 3 and 

Adobe Photoshop CS2
Automate image editing and file conversion using MediaPro 
with Adobe Photoshop droplets, Camera Raw plug-in and 
DNG Converter. Also: Streamline your metadata workflow.
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Figure 1.1: When a multi-layer Photoshop file is displayed in Media View, the Pager tool will appear in the Header bar.

Overview
Many professional photographers use the image 
editing program Adobe Photoshop for various tasks 
in their digital photo workflow. 

This solution guide covers several techniques 
for optimizing your photo management workflow 
with Photoshop and iView MediaPro.

View all layers of a Photoshop 
(PSD) file in Media View
1. Select a Photoshop file in your catalog and 

click on the Media View tab. 
2. On the right side of the Header bar (Figure 1.1) 

the Pager tool will appear. 
3. Use the arrows of the Pager tool to flip 

through the layers of the Photoshop file 
(Figure 1.2).  The first layer is a composite of all 
layers of a Photoshop file.

Assign a PSD layer as a thumbnail
Thumbnails for Photoshop files are based on a 
composite of all layers of the file. However, you can 
assign a specific layer as the thumbnail.
1. Select the PSD file in your catalog, go to 

Media View and use the Pager Tool to go to 
the layer you want to assign as the thumbnail.

2. In the Action menu, select Rebuild Item.
3. Return to Thumbnail View and you will see 

that the thumbnail has been reassigned to 
the specific layer.

Optimize thumbnails of PSD files
Photoshop embeds sharpened thumbnails when it 
saves files. This option is controlled in Photoshop’s 
Preferences › File Handling (Figure 1.3). When Always 
Save is selected in the Image Previews drop down 
menu, Photoshop creates thumbnails at 160 pixels. 
This is the default size and there are no options for 
adjusting the size of embedded thumbnails. (The 
default thumbnail size for Adobe Photoshop 7.0 
files is 128 pixels; for 6.0 files it is 112 pixels.)

If you have MediaPro’s Use built-in thumbnails 
option checked, thumbnails for Photoshop files 
may appear smaller than the thumbnail cell con-
tainer (Figure 1.4). When you rebuild it, the thumb-
nail size will match the rest of your catalog.

In the event that a Photoshop file does not have 
a built-in thumbnail, MediaPro will automatically 
create its own. 

Figure 1.4
A. Thumbnail created by Adobe Photoshop CS2
B. Thumbnail rebuilt by iView MediaPro

Go to composite Go to top layer

Go down one layer Go up one layer

Figure 1.2:  Pager Tool functions Figure 1.3:  Photoshop’s File Handling Preferences.
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Figure 1.5:  To add a Helper, click Add and navigate to 
the desired application on the desktop and select it. 

Figure 1.6: After selecting images, you can 
execute an Open With Helper command two 
ways:  In the toolbar’s icon (right) pull-down 
menu, or through a contextual menu. Right-click (Mac: 
Control-click) to access a contextual menu.

Batching & Automation
When browsing or viewing images in a MediaPro 
catalog, it’s likely that you will want to open these 
images with an editor such as Photoshop to make 
adjustments. To assist you, MediaPro has a func-
tion called Open With Helper Application. 

Helpers are defined in Preferences › Helper Ap-
plications. This dialog will let you choose Photoshop 
and/or other applications so that you may quickly 
access them via the pull-down menu in the 
MediaPro toolbar.

Assign Photoshop as a Helper Application
1. Select Edit › Preferences › Helper Applica-

tions.  (On the Mac, it’s under iView MediaPro 
menu › Preferences › Helper Applications). This 
dialog will let you choose Photoshop so that 
you may quickly access it via the toolbar or 
through a contextual menu. 

2. Click Add in the Define Helper Applications dia-
log (Figure 1.5). Navigate to Photoshop in your 
Programs folder (Mac: Applications folder) and 
select the program. 

3. Click OK.  Photoshop will be added to the list 
in alphabetical order (Figure 1.6). 

Open images with Photoshop
1. Select a group of images in your catalog.
2. Choose Adobe Photoshop in the Open With 

menu in the toolbar (Figure 1.6), or through a 
contextual menu. Right-click (Mac: Ctrl-click) 
to access a contextual menu.

3. Photoshop will launch and open the selection 
of files.

4. Make corrections to the images, then save 
them (replace the existing files, or as a copy to 
a new folder). 

5. When you go back to your MediaPro catalog, 
you will need to rebuild the images in order for 
the Photoshop edits to be reflected in the cat-
alog thumbnails. To do this, select the edited 
images and choose Rebuild Item in the Action 
menu. Rebuilding thumbnails is only neces-
sary when batching images in Photoshop. If 

you are editing only one image in Photoshop, 
MediaPro will automatically update the 
thumbnail for the image.

6. If you saved the edited images to a new folder, 
they will need to be imported into the catalog. 
To automate this, turn on Folder Watching with 
Auto Update for the folder that the images 
were saved in.
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Automate processes using 
ImageReady & Photoshop droplets
In Photoshop, an action is a series of recorded 
commands that you can apply to a single file or 
a batch of files.  Actions are the basis for droplets, 
which are small applications that automatically 
process all files that are dragged onto their icon.

Droplets can be integrated into your workflow 
by assigning them as Helper applications. Using 
droplets can save you a substantial amount of 
time when used as a Helper in MediaPro. 

Create a droplet in Photoshop 
The following is a quick example of creating a 
Photoshop droplet. For detailed instructions on 
creating a droplet with Photoshop, refer to Pho-
toshop’s Help documentation. 

1. To start creating a droplet in Photoshop, 
select File › Automate › Create Droplet.

2. Save: Define the location on your desktop to 
save the droplet. 

3. Play: In this section, you define the action that 
the droplet is based on. You can use any of 
the actions installed with Photoshop, or you 
can create you own actions. For this example, 
choose Sample Actions in the Set menu and 
Custom RGB to Grayscale in the Action menu 
(Figure 1.7). 

4. Destination: Define what Photoshop should 
do after processing the image. None will leave 
the file open in Photoshop; Save and Close will 
save the file and close it; Folder will save the 
image as a new file in a folder of your chosing. 
If you select the last option, you must define 
a file naming convention in the boxes below. 
For this example, choose Save and Close.

5. Click OK to create the droplet. The droplet you 
have created will convert any color image file 
(such as JPEG, TIFF or Photoshop) to grayscale 
and save it, replacing the original. (See Figure 
1.8 to see what droplets look like).
Tip: You can download additional Photoshop 

actions from web sites like Adobe Studio Exchange: 

www.adobestudioexchange.com. 

Using Photoshop droplets in MediaPro
1. Add the droplet as a Helper application (see 

instructions on page 4).
2. Select a group of images in your catalog.
3. Choose the droplet in the toolbar’s Open 

With menu.
4. Photoshop will launch, open the selection of 

image files and batch process them according 
instructions in the droplet.

Figure 1.8: Examples of droplets created by Adobe 
Photoshop (blue) and ImageReady (Orange).

Figure 1.7: In these menus, define which  
action the droplet will be based upon.
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Batch convert Raw files with the 
Photoshop Camera Raw plug-in
1. Select a group of Raw files in your catalog.
2. Choose Adobe Photoshop in the Open With 

menu in the toolbar. 
3. Photoshop will automatically launch and 

open the selection of files in the Camera Raw 
conversion dialog (Figure 1.9).

4. Each file can be individually processed or they 
can be batched and saved.

Batch convert Raw files to DNG
1. Select a group of Raw files in your catalog.
2. Choose Adobe Digital Negative (DNG) Con-

verter in the Open With menu in the toolbar. 
3. DNG Converter will automatically launch and 

open the selection of files.
4. All files are batched and saved based on the 

chosen settings (Figure 1.10).

Figure 1.9: When you open a group of images with Photoshop, the images appear in a thumbnail list on the left.

Figure 1.10: Digital Negative is Adobe’s publicly available, 
archival format for camera Raw files. This program is free 
and is available for download from Adobe’s web site. The 
Adobe Camera Raw plug‑in (Top) can save Raw image 
data in the DNG format as well.
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Batch convert images to the  
Photoshop (PSD) format
1. Select a group of images (JPEG, TIFF, etc.) in 

your catalog.
2. In the Action menu, select Convert Image Files. 

This feature will convert images into a new 
format, such as JPEG, TIFF, Photoshop, etc. 

3. In the Format drop-down menu at the top of 
the dialog, choose Photoshop (Figure 1.11).

4. Settings: Click the Size button to resize the 
image or use the existing dimensions; Click the 
Settings button to adjust the color depth; Click 
the Resolution button to define a custom dpi 
for the converted Photoshop file.

5. Options: Preserve color profiles will embed the 
ICC color profiles into the exported image. 
This option is only available if you have color 
matching turned on in the Preferences › 
Media Rendering › Images dialog; Check 

Embed annotations to write all IPTC/XMP Core 
annotations into each exported Photoshop file. 
EXIF/GPS metadata cannot be preserved when 
converting to the Photoshop format. 

6. Optional:  Apply a watermark to the exported 
Photoshop file by checking box and clicking 
on the Set Image button. For instructions on 
applying a watermark, see page 7. 

7. Click the Convert button.
8. Define a folder where you want to save the 

converted files.

Note: When converting any Raw image files, 
MediaPro uses the large embedded preview as 
the image to be converted. The actual raw data 
is not converted.

For frequent use of this feature, you can save 
settings using the Options menu. Saved options 
can be incorporated into scripts (Figure 1.12).

Choose Photoshop in 
the file format options 
menu.

Files: Replace 
original files 
will replace the 
original with 
the converted 
Photoshop file.

Figure 1.12: For repeat use of your settings, save them using 
the Options pop-up menu. Saved options can be recalled at 
any time and can be incorporated in scripts. This feature is 
standard to MediaPro export functions.

Settings: Click 
the Settings 
button to adjust 
the color depth 
of the converted 
Photoshop file.

Figure 1.11
Convert Images
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Watermark converted images
iView MediaPro can export converted images with 
a visual watermark — a secondary image which 
is overlaid on the primary image, and provides a 
means of protecting the image. This is not the same 
as digital watermarks which are implemented  
algorithmically and are designed to be invisible. 

Create and set a watermark
1. Launch Photoshop. MediaPro will accept the 

TIFF, PSD, JPEG, PICT, PNG, BMP, GIF formats 
as watermark files. Note that the JPEG format 
does not support transparency. iView recom-
mends PNG, TIFF or PSD for optimal results.

2. Create a new file. For this example, make it is 
200 pixels wide and 50 pixels tall. Make it RGB 
with Background Contents set to Transparent.

3. Choose the Type tool and type something 
with the color set to Black.

4. Choose Save. Select TIFF as the format. There 
is no need to save alpha channel or layer info.

5. In the next dialog, choose your desired com-
pression and check Save Transparency.

6. Return to MediaPro’s Convert Images function, 
and in the Set Watermark dialog, select your 
TIFF file by clicking the New Image... button.

Watermark options
The previous instructions will create an overlay 
where the logo’s color is opaque (such as 100 per-
cent black or white). 

To alter the logo color’s opacity and give it a 
transparent quality, adjust the layer’s opacity in 
Photoshop to somewhere between 50 and 90 
percent. To make it a little jazzier, as in the exam-
ple shown above, add following after Step 3:
a. Add a Drop Shadow filter to the text layer.
b. Set filter color to white or black, or whatever 

color desired.
c. You can adjust the opacity in the filter dialog 

to 75 percent for transparent quality.
Using a drop shadow will ensure your water-

mark is readable even if it falls in dark or light 
parts of an image.

Figure 1.13
Set Watermark: 
The preview of the 
watermark and the 
image will be blank 
until a watermark 
image is assigned.

Preview of currently 
assigned watermark.

Align: Click any 
of these boxes to 
adjust the relative 
alignment of the 
logo, where it will 
be overlaid on the 
exported image. 

Click the New Image... 
button to choose a 
different image. 

Use buttons to select the previous or next catalog image as the alignment preview image.
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Annotations

Using Photoshop metadata  
terminology in MediaPro
iView MediaPro and Adobe Photoshop CS2 sup-
port a set of pre-defined fields for annotating 
your media. This set, also known as IPTC/XMP Core 
metadata standard, enables you to define the 
author, event date, location, copyright and other 
metadata for your media files.

Some software programs use different names 
for the various IPTC/XMP field names. For exam-
ple, Photoshop CS2 refers the IPTC Job Identifier 
field as “Transmission Reference.”  

iView MediaPro 3 provides you with the option 
of choosing which field names to display through-
out the MediaPro interface: The official IPTC Core 
names; those names used in iView MediaPro 2; or 
those used in Photoshop CS and CS2.

To enable Photoshop metadata terms
1. Select Edit › Preferences › General. (On the 

Mac, it’s under iView MediaPro menu › Prefer-
ences › General). 

2. In the Field Names menu chose Adobe 
Photoshop CS (Figure 2.1.). This will change 
all annotations field labels to the terms that 
Photoshop uses in the File Info dialog and in 
Adobe Bridge.

Field names do not affect how annotations are 
written (synchronized) into media files. It is merely 
a visual preference designed to help you choose 
the appropriate field when annotating files.

Figure 2.2 lists the field names used by MediaPro 
and their corresponding names in the IPTC/XMP 
standard, as well as in Photoshop CS & CS2. Because 
the names of each annotation are not integrated 
into the data, other applications may refer to an an-
notation by a different name. 

Figure 2.1: Choose Photoshop in the Field Names menu.

* Supports multiple entries in field;  + Supported in Photoshop CS & CS2 
via iView plug-in (see page 11). For additional information on IPTC/XMP 
metadata, refer to the official web site: http://www.iptc.org/

Figure 2.2: Metadata field names table

iView MediaPro2 Photoshop CS, CS2 IPTC/XMP Core

Label	 Urgency Label

Title Headline Headline

Product Document Title Title

Genre Category Category

Intellectual Genre Intellectual Genre Intellectual Genre

Event Event + Event

Event Date Date Created Date Created

Author Author Creator

Credit	 Credit Provider

Source Source Source

Copyright Copyright Notice Copyright Notice

Transmission Transmission Ref. Job Identifier

Rights Usage Terms Rights Usage Terms Rights Usage Terms

URL Copyright Info URL URL

Location Location Location

City City City	

State State/Province State/Province

Country Country Country

ISO Country Code ISO Country Code ISO Country Code

Instructions Instructions Instructions

Status Status + Status

Writer Description Writer Description Writer

People * People + Contact *

Categories * Supplemental Cat. * Categories *

Keywords * Keywords * Keyword *

Scenes * Scenes * Scenes *

Subject Codes * Subject Codes * Subject Codes *

Caption Description Description 
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Using Adobe metadata templates 
for batch annotating in MediaPro
MediaPro and Photoshop both have metadata 
templates — a tool for saving a set of frequently 
used metadata and applying them to images.

In all of MediaPro’s metadata template menus,  
you can access any templates you may have pre-
viously created with Photoshop (Figure 2.3). 

These templates are acessible in MediaPro’s 
Metadata Template menu in the Info Panel. They 
are also accessible in the Annotate menu in sev-
eral import functions (Figure 2.5). 

Batch annotate using an Adobe Photoshop 
metadata template
1. Select a group of images in your catalog.
2. In the drop-down menu at the top of the Info 

Panel (Pencil icon), choose a metadata template 
in the menu (Figure 2.3). 

3. A dialog will appear showing the metadata 
that will be assigned by the template. You can 
turn some fields off to keep them from being 
applied to the images. When you are done, click 
the Apply button (Figure 2.4).

3. Click the checkmark icon (  ) at the top of 
the Info Panel to save the annotations. In the 
confirmation dialog, select Apply to All items. 
Now all selected images have the metadata as-
signed by the template.

To remove Adobe Metadata Templates
1. Locate Adobe’s templates folder: 

Mac OS X 
{User Directory}/Library/Application/Adobe/
XMP/Metadata Templates/ 
Windows 
\Documents and Settings\<user>\Application 
Data\Adobe\XMP\Metadata Templates\

2. Move the template file out of the folder or 
delete the file. 

Figure 2.5: Adobe 
Metadata Templates 
can be accessed in the 
Annotate menu of the 
Download and Import 
dialogs (From Camera, 
Disk or URL).

Figure 2.3: Adobe Metadata Templates are accessible in 
the Info Panel’s Metadata Template menu.

Figure 2.4: When applying a template, you can turn 
some fields from the template off.
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Round trip metadata: Syncing
Adding metadata to images in a MediaPro cata-
log does not automatically embed (write) the 
metadata into the original file. The metadata only 
exists in the catalog.

To write or embed metadata into an image, use 
the Sync Annotations function in the Action menu. 
This command allows you to embed annotation 
information from the catalog into the original files. 
It also allows you to import annotations, by rescan-
ning files for metadata added outside MediaPro 
with another application. 

This function is particularly useful, as MediaPro 
allows you to view, classify and batch annotate 
a large number of images and then export the 
changes to the original files, saving hours of time 
opening and editing individual files. 

Metadata that have been written into the image 
can be read by other applications that can read 
the IPTC, QuickTime or XMP metadata standards, 
such as Adobe Photoshop (Figure 2.6).

MediaPro supports the reading and writing of 
IPTC/XMP metadata to JPEG, TIFF and Photoshop 

formats only. MediaPro also can synchronize 
metadata in four Raw image formats: Nikon, Canon, 
Kodak and Adobe Digital Negative (DNG). 

Figure 2.6: If you enter annotations in MediaPro and export them to the original 
files, other applications such as Adobe Photoshop can read the metadata. 
Conversely, annotations added in Photoshop can be imported by MediaPro.

Figure 2.7: With this function, you can export (or write) 
metadata from the catalog to original files. You can also 
import metadata from original files.
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To embed (write) annotations in images
1. Select an image or group of images.
2. Enter all your annotations.
3. Choose Action › Sync Annotations.
4. Click the radio button for Export annotations 

to original files (Figure 2.7). The amount of time 
it takes to write annotations to files depends 
on the number of files selected. Regardless, it 
should be relatively fast.

To import annotations from files
This function is useful if you have edited annota-
tions in a file outside of MediaPro in another ap-
plication, such as Photoshop. Using this function 
will instruct MediaPro to reimport the annota-
tions for that file.
1. Select an image or group of images.
2. Choose Action › Sync Annotations.
3. Click the radio button for Import annotations 

from original files (Figure 2.8).
4. Choose between one of three options for 

importing annotations. Replace current clears 
any current annotations and replaces them 
with all annotations from the original file. With 
the Merge options, you need to define which 
set of annotations take precedence over an-
other when there is a conflict on single-value 
annotations. For example, suppose both the 
original file and the catalog item contain a 
Title annotation. Since there is only one Title 
annotation per item, you need to decide 
which one to use. Multi-value annotations, 
such as keywords and categories, are always 
merged together.

MediaPro’s special metadata  
plug-in for Photoshop CS & CS2
The Status, Event, and People IPTC annotation fields 
are not supported by Adobe Creative Suite. To ex-
tend support of these fields to Adobe Photoshop 
CS & CS2, iView provides a custom plug-in so that 
you can view and edit these annotations in the File 
Info dialog of Photoshop.

This plug-in also extends support of MediaPro 

Catalog Sets and any custom annotation fields cre-
ated in MediaPro.

Plug-in installation:
1. A file called “iViewPanel.txt” is automatically 

installed in your computer during the installa-
tion of MediaPro.

2. The file is placed in one of these locations: 
Mac OS X 
{Root Volume}/Library/Application Support/
Adobe/XMP/Custom File Info Panels 
or: {User Directory}/Library/Application/
Adobe/XMP/Custom File Info Panels 
Windows 
\Program Files\Common Files\Adobe\XMP\
Custom File Info Panels 
or: \Documents and Settings\<user>\ 
Application Data\Adobe\XMP\Custom File 
Info Panels

4. Open a file in Photoshop. Choose File › File 
Info. You will notice that there is a new panel 
call iView MediaPro (Figure 2.9).

Figure 2.8: When importing annotations, you must 
choose between one of three importing options.

Figure 2.9: iView metadata panel in Photoshop CS2.
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Star ratings in Adobe Bridge  
and iView MediaPro 3
Star ratings provide a ranking system for images 
in your catalogs.

Ratings in MediaPro are mapped to Adobe’s 
XMP standard for ratings. If you assign a rating 
to an image in MediaPro and synchronize (write) 
the metadata to the original file, the rating will be 
displayed in Adobe Bridge (Figure 2.10).

Conversely, images marked with star ratings 
in Adobe Bridge will maintain those star ratings 
when imported into MediaPro catalogs. 

Color labels in Adobe Photoshop  
and iView MediaPro 3
Labels in MediaPro are mapped to the IPTC/XMP 
standard’s Urgency annotation field. When anno-
tations for images in a catalog are synchronized 
(written) to the original files, all images tagged with 
a label will have the corresponding label number 
(1-9) written into the Urgency field. 

For Photoshop CS & CS2 users, these are the 
same values used in the Urgency field of the File › 
File Info › Origin panel (Figure 2.11).

Even if you have customized the colors and 
names of labels, the values 1-9 are written into the 
Urgency field in order to comply with the IPTC/XMP 
metadata standard. If the Urgency field is important 
to your workflow, you might customize the label 
names to match the standard (Figure 2.12).

Annotating DNG files in MediaPro
Import: MediaPro can import annotations on all 
Raw formats, including Adobe Digital Negative 
(DNG) files. MediaPro can also display the embed-
ded preview saved inside DNG files. MediaPro also 
imports metadata from any image file that has an 
XMP sidecar. 

Export: MediaPro can embed/write annota-
tions into four Raw formats: Canon, Nikon, Kodak 
and Adobe Digital Negative (DNG) files. MediaPro 
does not write annotations in other Raw formats. 
MediaPro also does not write metadata into XMP 
sidecar files.

Figure 2.10: Ratings marked in Adobe Bridge (B) are 
viewable in your MediaPro catalog (A). If you assign a 
rating in MediaPro and synchronize (write) it to the file, 
it will be shown in Adobe Bridge.

A B

Figure 2.12: MediaPro’s color labels can be named to 
match the values in Photoshop’s Urgency field.

Figure 2.11: Color labels in 
MediaPro correspond to the 
Urgency field used in the Origin 
panel of the Photoshop File 
Info dialog.
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Why can’t I use Photoshop CS as a helper 
application? (Mac only)
There can be a problem with any application, 
including MediaPro, that tries to use Photoshop 
CS as a helper application. Photoshop CS will 
launch but the selected images will not open.

The solution is to reinstall Photoshop. You may 
find other answers by searching Adobe’s support 
web site.

This layered Photoshop file was not saved 
with a composite image.
If an imported Photoshop image displays this mes-
sage in MediaPro, “This layered Photoshop file was 
not saved with a composite image,” the PSD file 
was not saved with Maximize Compatibility turned 
on. This can be fixed two ways.
1. When saving files in Photoshop, make sure 

the Maximize Compatibility option is checked 
(Figure 3.1).

2. In Photoshop’s Preferences › File Handling 
dialog, set the Maximize PSD File Compatibility 
drop-down menu to Always to automatically 
save PSD files with maximum compatibility 
(Figure 3.2).

Alpha channel in Photoshop file incorrectly 
displayed (typically yellow).
Some Photoshop documents with alpha channels 
can be incorrectly displayed. MediaPro sometimes 
interprets the alpha channel as a transparent layer.
MediaPro displays transparencies as a specific 
color and by default this is yellow. See example in 
Figure 3.3.

To correct this, turn on the Use Alpha Channel 
setting (Figure 3.4) in the Preferences › Media Ren-
dering › Images dialog.

All newly imported Photoshop files will be dis-
played properly. To correct existing thumbnails 
you need to select them and choose Rebuild Item 
in the Action menu.

Appendix: Troubleshooting

Figure 3.1: When you save PSD files in Photoshop make 
sure Maximize compatibility is checked to ensure proper 
rendering of these files in iView MediaPro.

Figure 3.2: To ensure your PSD files are save with 
maximum compatibility, choose Always in this menu of 
Photoshop’s Preferences › File Handling dialog.

Figure 3.3: The yellow area is an example of alpha 
channel displayed incorrectly.

Figure 3.4: In order to properly display Photoshop files 
with alpha channels, make sure this box is checked.
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